Installing CMake

The rest of the projects in this course require a recent version of CMake, preferably v3.17, with v3.14 as a minimum. To find out your version of cmake:

cmake --version

WSL2 (Windows Subsystem for Linux)

On Windows, the WSL may be an older install of Ubuntu Linux.

Kitware has an APT repository for Ubuntu. Follow the instructions at https://apt.kitware.com.

macOS

Using brew to install cmake provides a recent version. If you have not already installed Homebrew, please do so. To make sure it is installed with the most recent version, enter the following commands in a terminal:

brew upgrade
brew install cmake

Linux

Instructions depend on the distribution. If you are using an older version of Ubuntu, follow the WSL instructions.